CPD Diário

Nosso dia-a-dia

[Dica] CPD também ensina coisa errada: chrome sem verificação de plugins

fevereiro 28, 2012 CPD Dicas, Tutoriais 4 Comments
tutorial

Como assim? O CPD vai ensinar coisa errada??

Ah, você já deve estar pensando “é hoje que eu aprendo a hackear o site da faculdade, ou burlar o proxy da empresa!”, não é mesmo? Pois sinto desapontá-lo, nós ainda não vamos ensinar esse tipo de coisa por aqui (pelo menos não de graça).

A dica do dia é algo mais inofensivo, mas não menos útil, principalmente para quem tem um proxy amaldiçoando sua já infeliz vida profissional.

O Google Chrome, nosso navegador preferido (jabá not intended), possui um sistema bem interessante de verificação de status da versão dos plugins instalados nele, isto é, ele verifica se os plugins instalados estão atualizados (updated) ou se estão em uma versão antiga (outdated) e potencialmente perigosa. Isso é uma vantagem para o usuário, pois o força a estar com todos os plugins atualizados, o que diminui o risco de roubo de dados e outros perigos na internet. No entanto, isto se torna um problema quando você não quer atualizar um plugin, talvez por motivos de incompatibilidade com algum sistema que já esteja utilizando e é sabidamente incompatível com a nova versão do plugin (aplicativos em cof cof java cof atchim!), ou então o que tem sido o maior problema: um proxy mal-configurado que impede a atualização de plugins, principalmente quando esses plugins insistem em disponibilizar um instalador que ainda vai fazer um download, ao invés de facilitar o acesso ao instalador off-line, que você poderia baixar usando o proxy configurado em seu navegador (cof cof java atchoo!).

Com o plugin desatualizado, o Chrome começa a exibir, a cada requisição de execução do tal plugin, um alerta de risco, no qual você é obrigado e clicar para autorizar o carregamento do plugin e continuar navegando na página/sistema. Exemplo clássico: página de acesso a bancos.

Hey Apple! (lembra da annoying orange? então...)

Depois de todo esse discurso, vamos aprender em um passo simples como nos vermos livres desta mensagem chata sem ter de atualizar imediatamente o plugin.

Pesquisando no suporte da Google, descobri que é possível forçar o carregamento do Chrome com a opção de permitir plugins desatualizados, e é isto que vamos fazer. Para isto, é necessário apenas acrescentar um parâmetro após o comando de carregamento do navegador. Este parâmetro deve ser colocado no link de carregamento do Chrome, ou utilizado na linha de comando sempre que se quiser executar o programa. Pelo Windows, o procedimento é o seguinte:

  • Clique com o botão direito sobre o atalho do Chrome, e selecione a opção Propriedades
  • Será exibida uma caixa de diálogo, como mostra a figura abaixo; nela, após o caminho completo do aplicativo, insira o código –allow-outdated-plugins – veja a imagem para detalhes:

agora vai!

Feito isto, basta iniciar o Chrome novamente e pronto! Diga adeus as malditas mensagens e insistências de cliques em botões!

Mas atenção que nem tudo é festa: obviamente, estamos ensinando um procedimento não aconselhável, principalmente se você está em seu computador pessoal e sem nenhum bloqueio, ainda mais se acessa sites de bancos. Esta dica é para quebrar um galho de quem tem um administrador de redes de talento duvidoso ou para casos em que é necessário utilizar uma versão do plugin para não ocorrer conflito com algum sistema já em uso. Se você não se enquadra nessas categorias, aconselhamos que faça a atualização do plugin, pois com isso seu computador estará (ligeiramente) mais seguro menos vulnerável.

Agora que ensinamos a fazer coisa feia, vai lá e conta pros seus colegas! 😛

Para saber como configurar em outros Sistemas Operacionais, visite esta página.

(Conteúdo adaptado de Suporte Google)

Compartilhe!

Sobre o Autor -

  • Aprado

    E no linux, teria algo pra postar ai?

    • bramax

      Taí uma boa ideia, vou procurar pra ver se tem solução semelhante e posto aqui se achar!

  • Anita

    Não deu certo desta maneira. ele não deixa eu aplicar a alteração. =/

    • bramax

      Qual sua versão do Windows? E qual mensagem aparece quando você insere o código e tenta salvar?